Grove Pi Plus integ...
 
Notifications
Clear all

Grove Pi Plus integration with Mycodo  

Page 3 / 3
  RSS

Kyle Gabriel
(@kylegabriel)
Member Admin
Joined: 6 years ago
Posts: 275
July 20, 2020 3:20 am  
Posted by: @cboy

pi@raspberrypi:~ $ sudo i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: -- 04 -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- 29 -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- 44 -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

...

I edited as you said and it allowed me to select the 0x39 address. Still not showing data.

The edit allowed you to select 0x29, which is the address that showed up in your device tree.

Mycodo Developer


ReplyQuote
Kyle Gabriel
(@kylegabriel)
Member Admin
Joined: 6 years ago
Posts: 275
July 20, 2020 3:24 am  

I'm not sure what's going on with your DS18B20. I'm also not familiar enough with Grove boards to really help more. Might want to see if a Grove forum exists that you can discuss that issue.

Mycodo Developer


ReplyQuote
cboy
 cboy
(@cboy)
Active Member
Joined: 4 weeks ago
Posts: 18
July 20, 2020 3:27 am  
Posted by: @kylegabriel
Posted by: @cboy

pi@raspberrypi:~ $ sudo i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: -- 04 -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- 29 -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- 44 -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

...

I edited as you said and it allowed me to select the 0x39 address. Still not showing data.

The edit allowed you to select 0x29, which is the address that showed up in your device tree.

Very Sorry I meant to Say 0x29!!

I am getting a popup of "Error: Cannot activate Input controller with ID ccd65e87-0dc7-40ec-95e4-8e6e4b319862: It's already active."

When trying to activate the light sensor with the 0x29 address selected. Still no data displaying

 


ReplyQuote
cboy
 cboy
(@cboy)
Active Member
Joined: 4 weeks ago
Posts: 18
July 20, 2020 3:29 am  
Posted by: @kylegabriel

I'm not sure what's going on with your DS18B20. I'm also not familiar enough with Grove boards to really help more. Might want to see if a Grove forum exists that you can discuss that issue.

I was having this issue with the last setup that I made my own PCB with the resistors etc for the sensors. It just kept changing rolling addresses and the temp sensors wouldn't work. I dont know how it could be something I have done in mycodo or not...

 


ReplyQuote
cboy
 cboy
(@cboy)
Active Member
Joined: 4 weeks ago
Posts: 18
August 8, 2020 8:34 pm  

Hey mate,

So I replaced the Grove Pi plus board with the  Grove Pi Base board which is a more basic board, more of a just a splitter.

 

I've now got the DS1820B to display temperature. I believe the Plus board uses some kind of chip to enable more sensors on the bus and this wasn't allowing it to talk to Mycodo.

 

This worked only by using your custom GrovePi plus input that you made me.

My issue is now that I have 2 of these temp sensors and If I add a second input it just reads the first sensor in the D5 slot.

 

How do I modify it to get the second one to work seperately?

 

Thankyou!


ReplyQuote
Page 3 / 3